Many unsupported tables shown for my ROM

Report bugs/problems with ecuEdit

Many unsupported tables shown for my ROM

Postby NSFW » Mon May 10, 2010 7:32 am

I have an 05 Legacy GT, calid A2WC510N. When EcuEdit shows the list of tables for my ROM, the list includes many tables that don't actually exist in my ROM.

For example in the Primary Open Loop section it shows the "KCA additive high" and "KCA additive low" tables. If I click on them, the show up as tables of random numbers. Also, in the Ignition Timing - Advance section, it shows Base Timing (which exists) and Base Timing A, B, C... H (which are more random numbers). I think those only exist in some Impreza ROMs, like STI.

Is there a way to make ecuEdit hide the tables that aren't actually supported in my ROM?

Thanks!
NSFW
 
Posts: 4
Joined: Thu Sep 03, 2009 4:14 am

Re: Many unsupported tables shown for my ROM

Postby epifan » Wed May 12, 2010 10:29 am

You can switch to "Show only active maps" in mapList window.
epifan
Site Admin
 
Posts: 825
Joined: Thu Jul 13, 2006 3:17 pm

Re: Many unsupported tables shown for my ROM

Postby NSFW » Thu May 13, 2010 8:44 am

Thanks!
NSFW
 
Posts: 4
Joined: Thu Sep 03, 2009 4:14 am

Re: Many unsupported tables shown for my ROM

Postby NSFW » Tue Jun 01, 2010 8:04 pm

I added a new map to the definition for the ROM I'm working with, and this has apparently set all maps to 'active' so now I have the original problem again (tons of tables shown that don't exist in my ROM) but this time setting it to show 'active' maps doesn't fix the problem.

Is there a way to set all nonexistent tables back to 'not active?' There are too many of them to do that by hand. :)

Thanks!
NSFW
 
Posts: 4
Joined: Thu Sep 03, 2009 4:14 am


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 0 guests